6.14. Version 1.9 (February 4, 2008)

This version adds many features and improvements that make Fanurio even more easier to use. Here's a list with all the changes:

New Features

  • More project reports: The current project reports have been improved and others have been added.

    Project reports can be accessed from the Reports menu. Users can now see project time by date, project, week, month or year.

  • Import Address Book contacts on Mac OS X: Fanurio can import contacts from Address Book. Go to File > Import > Address Book Contacts to choose which contacts should be imported as clients in Fanurio.

    You can also synchronize your Fanurio business contact information with that from Address Book. Go to Business > My Business Details > Contact and click the Import from Address Book button. Your Address Book contact information will be copied to Fanurio.

    Fanurio can now import contacts from Address Book and from a CSV (comma-separated values) file. All major applications (especially e-mail applications) that keep a list of contacts can export them to CSV.

  • Detect idle time on Mac OS X: Idle time detection happens when you start the timer but at some point you must leave the computer. This option is not enabled by default and must be configured from Preferences > Timer.

    Until now, idle time detection only worked on Windows. Now, it is also available for Intel and Power-PC Macs that run Tiger (Mac OS X 10.4) or Leopard (Mac OS X 10.5). Previous versions of Mac OS X don't have a reliable method to detect idle time.

  • Move time entries: Time entries can now be moved from one item to another. To do it, open the edit dialog for the item that contains the time entry, go to the Time section and then use the Move button to move it to another item.

  • Filter project items: The list of items from a project can be filtered to show invoiced items, uninvoiced items or both. This feature is useful if your project has many invoiced items and you want to hide them.

    To specify which items should be displayed, click on the top-right button from the items table and select from the popup menu one of the options: All Items, Invoiced or Uninvoiced.

  • Purchase order number: Every time an invoice is created, it is associated with a contract. Fanurio lets you specify both your contract number and your client's number. The client's number is usually a purchase order number.

    A new set of placeholders can be used to access these values from an invoice template. Read this section for more information.

  • Foreign clients: Many freelancers work with both domestic and foreign clients. When working with foreign clients, they may want invoices in their own currency with numbers displayed according to their country rules. For instance, some countries use comma as decimal separator while others use a dot. Dates may also be formatted differently. Some countries display the month first while others display the day of month.

    Fanurio lets you specify if a client is domestic or foreign. If clients are foreign, you can also specify the client's country so that when invoices will be created for them, numbers, dates and currency will be formatted correctly.

    Let's say that you are from Scotland and most of your clients are from the UK but you also have a few clients from the USA. When dealing with clients from UK, you will be invoicing in GBP while for the American clients the invoices will be in USD. By marking a client as being from the USA, all invoices created for him or her will show numbers, dates and currency formatted using American rules.

    Here's how to mark a client as foreign:

    1. Go to the projects view

    2. Select the client from the projects tree

    3. Edit the client (right-click on the tree node and select Edit or double-click on the node)

    4. Go to the Billing tab, check the "This is a foreign client..." option and then select a locale to indicate the country

Improvements

  • Preview Invoice: Invoices are displayed like they will appear on paper, if printed. A black border is used to show the page limits.

  • Add time to item: You can now add time to an item by specifying only the total time. Select the none option from the Add Time dialog and you will not be asked to specify when the activity started or ended. This is useful if you are not interested when you've worked during a day.

    The Add Time dialog also remembers how users like to enter time: by start time, by end time, by both or none.

  • Minimize to tray bar on Windows: The Windows version of Fanurio can be configured to minimize to the tray bar from Tools > Options. By default, it is minimized to tray if the application window is closed. Other options are: never, on minimize and on minimize or close.

  • Higher precision on tax calculation: Taxes are calculated using a 4 decimals precision.

  • Delete older backups: If auto-backup is enabled, you can also tell Fanurio how many backups to keep. The older ones will be automatically deleted.

    To specify how many backups to keep, go to Preferences (on Mac) or Tools > Options (on Windows) and enter a number.

Bug Fixes

  • When exporting invoices to PDF, some fonts where not rendered. To fix this problem, copy the font file to the templates folder.

    This folder can be accessed from the menu File > Show Templates.

  • Fanurio crashed on some Macs because it didn't update the dock icon badge correctly.

  • Fanurio failed to display invoices if it was set to use the first template from the list of templates.

  • Fanurio failed to start if it used a language only locale.

  • Failed to display images when viewing invoices.

  • The today date from the status bar and the date filters were not updated if the application ran after midnight.

  • The View menu was not synchronized correctly.

  • Spinners didn't always accept new typed values on Mac OS X.